Cant connect to servers

Discussion in 'In-Game Support Archive' started by THE GMoD, Jun 2, 2011.

Thread Status:
Not open for further replies.
  1. c00pala

    c00pala Green Slime


    See here: http://www.terrariaonline.com/threads/multiplayer-server-help.20436/
    Has anyone checked to see if the 'new' server application (TerrariaServer.exe) is blocked by a Firewall?

    What people seem to be missing here is that there's now two ways to launch the same server via different programs. The old, or normal way, through the game (Host and Play) and now via the new way, by launching the TerrariaServer.exe file (the dedicated command line server). If the server operator hasn't added the new one (TerrariaServer.exe) to be excepted in their firewall, then it's not going to let anyone connect.

    On a side note - Assuming that this is actually a coding issue, if you guys want the Devs to take this seriously, you need to start troubleshooting and providing information that would actually prove this is a coding issue. You're going to have a hard time convincing them that their application is broken when a ton of other people are hosting and playing on the new server (over Hamachi or otherwise) fine. Simple logic, if it works for people who seem to know what they're doing, whereas the people reporting issues don't seem to, then where do you think they're going to assume the problem is?

    Don't mean to be harsh, sorry, just trying to put this into perspective for you. You need to help them, to help you, ya get me? Maybe I need to write up a troubleshooting guide..
     
    Trunus likes this.
  2. keivo225

    keivo225 Green Slime

    win7 ultimate 64 bit here
     
  3. xga

    xga Green Slime

    same problem
     
  4. firebomb428

    firebomb428 Green Slime

    same problem and i have my firewall turned off
     
  5. Rex Baker

    Rex Baker Green Slime

    goddamn and i thought i was the only one, i just started trying to get into multi 2day since the update and im kinda pissed that its not working
     
  6. c00pala

    c00pala Green Slime

    It's not the firewall of the player, the issue is with the server.
    Have any of you tried connecting to another server to if that works?
     
  7. Smuggles

    Smuggles Green Slime

    I've turned off my firewall and enabled the port thingies, it worked before and it should work now but it doesn't. It doesn't work for any of my 7 friends that have Terraria either...We can't connect to each other's servers and play, it's a pretty big problem seeing as thats the main thing the game has going for it :/
     
  8. iHeroYuri

    iHeroYuri Green Slime

    Well, since Terraria came out I`ve never been able to connect online when this problem goes, I hope I`m able to go online.
     
  9. Rex Baker

    Rex Baker Green Slime

    im sure this is a 1.0.3 update problem, i mean its pretty bad but with the consistancy of the updates being released give it one or two days, i guarentee itl be fixed by then, but i never said there wont be a new problem XD ex. 1.1 update couldnt connect, 1.2 update i could. 1.3 i cant......
     
  10. T3G Silas

    T3G Silas Green Slime

    Quoting for the truth. ^
    There's nothing wrong with the coding, actually.(Except maybe performance issues with some people) However, people are fairly careless when it comes to forwarding and making exceptions, whether it be doing it wrong or completely ignoring it and leaving their server on anyways.
     
    Trunus likes this.
  11. HooberDooberMan

    HooberDooberMan Green Slime

    No there is a legitimate problem i don't know what is wrong maybe it is a technical glitch or maybe it's a coding error i was running a server for a couple weeks with a couple of my friends and it worked fine. Then when 1.0.3 came out i couldnt connect to servers or host one. Meaning that my friends could not connect to it. I turned all my security settings (including my firewall) off and it still didnt work. Then I though maybe its my port forwarding and i triple checked and it wasnt. Then i thought well i will just go on a public server but I couldnt connect but all my friends could. I've come to belive through research that it is an issue that prevents older OS like Windows XP from connecting to/hosting online servers. I don't care what it is I just want it fixed.

    I best any money you don't have windows xp and why would you search for an article like this just to tell people that they are wrong. That's like going to a restaurant just to complain about the food. We're not perfect but we're not idiots.
     
  12. Trunus

    Trunus Green Slime

    I run the server flawlessly. I also run windows XP.
     
    T3G Silas likes this.
  13. Jeddac

    Jeddac Green Slime

    The point people are trying to make, is that it's not their idiocy that's causing the problems, i have the same problem that i didn't have beforehand, with the same settings, i'm using host and play and trying to connect, and getting this issue, i was playing just before the update on multiplayer, then straight after me and my brother updated, i couldn't connect anymore, it's not an issue with my settings, evidently.
     
  14. Trunus

    Trunus Green Slime

    Please look over http://www.terrariaonline.com/threads/guide-getting-multiplayer-working-1-0-3.22063/
    It is a guide by T3G where he shows that there is a new program name that needs to be added to the exceptions. So since you are using the same settings as 1.0.2 and it is not working. They added the new thin server for dedicated servers. I have double checked this by running a host and play server and checking task manager. NewProcessName.JPG
    I use process explorer so it looks different than yours, but it still displays the new exe being used.
     
    T3G Silas likes this.
  15. T3G Silas

    T3G Silas Green Slime

    I'm adding that to my thread for added clarification.
     
    Trunus likes this.
  16. Trunus

    Trunus Green Slime

    Thanks! :cool:
     
  17. Jeddac

    Jeddac Green Slime

    Didn't make a difference at all ><
     
  18. T3G Silas

    T3G Silas Green Slime

    Don't forget about standard firewalls you may have(I suggest disabling them for testing, then properly adding exceptions after).
     
  19. Jeddac

    Jeddac Green Slime

    I'm using hamachi, as i was before the update 'cause i'm too lazy to portforward again :p
     
  20. iHeroYuri

    iHeroYuri Green Slime

    I disagree, I have this problem and I use Windows Seven.
     
Thread Status:
Not open for further replies.

Share This Page