Pre 1.2 Dedicated Server on Linux

Discussion in 'Guides' started by Terraria.net, Jun 2, 2011.

  1. Terraria.net Green Slime

    Heyho, i am actually trying to get that new dedicated Server .exe to run under Linux.

    At the moment im at the point that it is neccessary to get wine, since its extension is .exe

    After i tried that and set up an vnc server with fluxbox running (needed, since it stupidly wants to create a window) this is happening:
    "wine: Install Mono 2.8 or greater for Windows to run .NET 4.0 applications.", weird as i have Mono 2.10 for that. I may need to install .net 4.0 by myself.

    Lets see if i destroy the dedicated server or just fail.

    When i made it and run dedi terraria server under linux ill inform you here and post a guide.

    Zero compatibility with .NET Framwork 4.0 makes the dedicated server unable to run.

    Good job. For fuck sakes who want windows dedicated servers!
    FaTony likes this.
  2. Snoopunit Green Slime

    ill be watching this thread :D can't wait to host a server on my linux box
  3. Ron Lenzi Green Slime

    Yep, I just got Mono 2.10 installed on my Ubuntu server running Gnome-Desktop. When I VNC to the box (it's headless) and try to run the terrariaserver.exe , the VNC window closes and the VNC session is locked until I kill the process and launch it again (I'm using tightvnc).

    I'm going to try and hook up a keyboard / mouse / video to the server tonight and see if I'm getting any kind of errors when trying to launch terrariaserver.exe before the VNC window is closing. That might give a little more insight into what's going wrong.
  4. Terraria.net Green Slime

    Uhm well that vnc is crashing isn't happening here, thats odd i guess.

    The CLI Window is just shutting down for not having .NET Framework 4 installed.
  5. Brent Green Slime

    virtualbox that shit
  6. TheWolfie Green Slime

    i toooooold you <3
  7. Terraria.net Green Slime

    GTFO TheWolfie, you told us shit like blah steam doesn't work on Linux. IT DOES. Its just freaking Terraria Netcode i guess needing .NET 4 for some random reason.

    Lol Virtualbox... yes of course...
    FaTony likes this.
  8. Brent Green Slime

    vbox works, steam works in wine, most steam games do not work in wine, thus steam is largely useless on linux.

    as I said, vbox that shit, it'll work, and you can get the windows VM on the internet, you just need an install of windows 7
  9. psychokilla Green Slime

    I've been trying this too with no joy.

    See this thread.

    See if you get any joy copying the .net 4 files into the terraria folder, I'm not too sure which files I should be putting in there.
  10. FrozenCow Green Slime

    I have it running on my desktop (the game and the server). Both require .NET Framework 4 and XNA, though it requires some weird stuff to get this set up right. These links are for the main game, but if you place the terrariaserver executable in the directory as the main game, you should be fine:
    http://www.terrariaonline.com/threads/terraria-macos-and-linux.1397/page-2#post-85844
    You can also try:
    http://www.terrariaonline.com/threads/terraria-macos-and-linux.1397/page-5#post-274846
    Please tell me what works, if it works at all :p.
  11. Mr. BG Green Slime

    The dedicated server should work in wine no problem. Just follow this guide:

    http://tom-geiger.de/?p=163

    Not sure if trying it through a VNC session would matter. It should not, so you should be in good shape. I have tested the server exe in wine and it starts properly.
  12. Nagol Demon Eye

    You didn't tell anybody anything, nobody in that other thread was arguing that THIS dedicated server could work in Linux. We were simply try to get it through your head that it MIGHT be possible for there to be a Linux VERSION of the server software at some point in future. At least, that's what I was trying to explain, while you blindly just ignored everything being said and went "lol won't work".
    FaTony likes this.
  13. Mr. BG Green Slime

    Hey FrozenCow, have you been able to both host and join your server on the same PC under Linux?
  14. Ron Lenzi Green Slime

    Yeah, I was looking at this guide. When it says: "Install Mono via Wine Tricks", when I go to an application install through Wine Tricks, there is no Mono 2.8 or 2.10 in the list to select.

    I have Mono 2.10 installed, but like I said, when I try to run something with Wine through my VNC using Real VNC (and TightVNC Server on the server-end), my VNC window closes and the session locks up until I kill the process and start it again.

    As for the "Just Virtual Box it!" - I'm not purchasing another copy of Windows 7 (or Windows XP, or any other Microsoft OS that works with .NET 4.0) to install on my already functioning Linux server. The best solution would be if the developers of Terraria could make a linux-compatible dedicated server. I don't know if this is even possible, as they may not be able to convert the code to work without .NET 4.0. I've already over-stepped my server admin duties and installed Gnome-Desktop on Ubuntu Server, which I wasn't happy about. I will keep trying to get this to work though. It is definitely worth it.

    Once I have the chance, I'll get a monitor hooked up to it and see exactly what error it's giving me before my VNC session gets terminated.

    Until then, I'm just running the command-line server on my Windows 7 machine. It sits idle most of the day, and when it's not idle, it's used for web browsing and Word / Excel. I just needed to let my wife know to ignore that command line application running in the task bar, and please don't close it. :)
  15. Mr. BG Green Slime

    Code:
    winetricks mono208
    winetricks mono210
    That would install both versions of Mono.
    After that just proceed with the guide. Terraria and the server work in Wine -- just not sure what role the VNC tunnel would play.
  16. Ron Lenzi Green Slime

    Wine was giving me a display error when I was attempting to run it from an ssh session. That was remedied by using VNC to the Gnome-Desktop.

    As for the code you just gave, this is what I get on my server:
    Code:
    r:~$ winetricks mono208
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    err:systray:initialize_systray Could not create tray window
    Unknown arg mono208
    Doing 'winetricks 210' does work, but I already have 210 installed. I tried 'winetricks 280' as well. I received the same Unknown arg response.

    This isn't going to work from an SSH session, as installation needs to open up a setup window, like you'd normally get in Windows. I can't open a window from a command line SSH session, which is where the VNC comes into play. This is a headless server.

    Also, the guide is for getting Terraria to run on Linux. I don't need to get the graphical Terraria game to run. I only require the command-line server. The command-line server does not require Steam to be running in order for it to execute. I tested this on my Windows desktop.

    EDIT:

    It's 'winetricks 28' . I'll see how far I can get doing this...

    EDIT #2:

    As expected, I cannot do any install or executables from the SSH command line, because I am not in a GUI environment. After Mono 2.8.2.exe was downloaded, this is what happens:
    Code:
    Executing wine /home/crafty/.cache/winetricks/mono28/mono-2.8.2-gtksharp-2.12.10-win32-1.exe
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    err:systray:initialize_systray Could not create tray window
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    fixme:msg:ChangeWindowMessageFilter c03d 00000001
    fixme:win:DisableProcessWindowsGhosting : stub
    ------------------------------------------------------
    Note: command 'wine /home/crafty/.cache/winetricks/mono28/mono-2.8.2-gtksharp-2.12.10-win32-1.exe' returned status 1.  Aborting.
    I'll have to attempt this from the VNC, but as I said, any time Wine tries to execute something, it closes my VNC window. I think I'm back to having to hook up a keyboard / mouse / monitor to the server and attempting it from there.
  17. FrozenCow Green Slime

    Hmm, it doesn't seem to be working with both the client -and- the server running simultanious. I also found that you can only run TerrariaServer.exe correctly using wine's command-prompt:
    Code:
    wineconsole --backend=user TerrariaServer.exe
    When the client is also started it'll give a SocketException.
  18. Mr. BG Green Slime

    I am not a Linux expert, but I am pretty sure there is a way to forward X through SSH as well. That would give you your graphical interface :).

    I use Arch Linux, but you could do it the same way in any Linux I am pretty sure. I just love their wiki... Scroll down to X11 Forwarding:

    https://wiki.archlinux.org/index.php/SSH
  19. Patchumz Dark Caster

    You'll need a custom server client, cuz the official one still uses XNA and stuff. Most likely at least.
  20. Mr. BG Green Slime

    Bro, as stated above, we are already running servers in Linux no problem. It is a specific situation that is under discussion.

Share This Page