Released Game Launcher 3.0

Discussion in 'Released Mods' started by Eikester, Apr 22, 2013.

Thread Status:
Not open for further replies.
  1. dragonid1423

    dragonid1423 Cursed Man

    Joined:
    Apr 28, 2011
    Messages:
    1
    Likes Received:
    0
    All I get is the the Hash value Terraria.exe is incorrect! Make sure you have a legal copy of the game!

    I do, Even the old launcher told me this.
     
    #101
  2. Tunnel King

    Tunnel King Moderator Staff Member

    Joined:
    May 25, 2012
    Messages:
    5,264
    Likes Received:
    5,226
    See my previous post. GL currently not working for new installs.
     
    #102
  3. jac1011

    jac1011 Angel Statue

    Joined:
    Oct 2, 2013
    Messages:
    4
    Likes Received:
    0
    Thanks testing it right now
     
    #103
  4. jac1011

    jac1011 Angel Statue

    Joined:
    Oct 2, 2013
    Messages:
    4
    Likes Received:
    0
    yeah... you should be a god :D (no kidding) btw sorry for my english i speak mostly french
     
    #104
  5. Tunnel King

    Tunnel King Moderator Staff Member

    Joined:
    May 25, 2012
    Messages:
    5,264
    Likes Received:
    5,226
    Eikester (author) confirmed that there needs to be a small change made to make GL work with 1.2, you can probably expect an update soon.
     
    #105
    Yoraiz0r likes this.
  6. master-chief

    master-chief Angel Statue

    Joined:
    Jul 3, 2013
    Messages:
    3
    Likes Received:
    0
    the new luncher deleted all my terraria data
     
    #106
  7. Eikester

    Eikester Possessed Armor

    Joined:
    May 24, 2011
    Messages:
    940
    Likes Received:
    1,576
    Added Update 3.1

    Works now with 1.2.0.1
    Added Menu to Install Older Terraria Versions
    • this feature is experimental, use at own risk
    • currently only 1.1.2
    • 1.0.4 is disabled because it causes a crash (will be added in together with other Versions like 1.0.6)
    • this only works against the latest legit Terraria version
      • when an update comes out i will need a few hours to update the diff Patches
    • this only patches the exe to an older version (you will have the new Tile/Item Graphics and Sounds for now)
    • !Works by using diff patches, no original files will be shared!
    If you have problems installing the Launcher try to Redownload Terraria and install GL again
    Also its always a good idea to run the Installer as Administrator
     
    #107
    anothersarah and Tunnel King like this.
  8. Splinti

    Splinti Green Slime

    Joined:
    Oct 3, 2013
    Messages:
    1
    Likes Received:
    0
    The link for the 3.0.1 Update and the 3.1 Update all leads to the 3.0 version... Normal?? Because with the 3.0 version It says I cannot install it, because the hash value for terraria.exe is wrong
     
    #108
  9. Tunnel King

    Tunnel King Moderator Staff Member

    Joined:
    May 25, 2012
    Messages:
    5,264
    Likes Received:
    5,226
    Addendum to my earlier post: you can start both 'classic' Terraria and tConfig, along with 1.2, from the Game Launcher, but there are some caveats.
    1. Both old and new Terraria use the same 'config.dat' file for the game settings/control configuration. They expect them to be in different formats, however. So, running one after having run the other will cause problems with sound volume, movement controls, etc. A work-around would be to maintain separate copies of this file, and manually copy the one you need into place before running the app.
    2. Terraria (at least the old version) had hard-coded path names to find content (the sprites, sounds, music, etc.) So, running 'classic' Terraria picks up the new 1.2 sprites instead of the old ones, and it looks kind of funky. A work-around would be to create a 'classic' textures/sounds/fonts/music pack for TCCL/TCCLtC.
    Eikester, when/if you update TCCL/TCCLtC for 1.2, would you consider leaving in legacy support for 1.1.2? Even if you just had the current 1.1.2 versions as unsupported downloads, and separate new versions for 1.2 and beyond, that would be appreciated.
     
    #109
    Zer0 Th3 Fall3n likes this.
  10. Grox the Great

    Grox the Great Snatcher

    Joined:
    Mar 14, 2013
    Messages:
    236
    Likes Received:
    294
    I'm having a problem with game launcher 3.1, I can't run 1.2 through it. Every time I try, it tells me to 'run it through steam', which is the normal response if you just try and run the .exe manually. I am not sure what changed, but because of this I cannot run 1.2 through the launcher making it's use fairly pointless.

    Yes, I have a legit copy and yes, it's on steam and yes, it runs fine on it's own and yes, I can run tConfig from the launcher, it is only 1.2 that has this problem.
     
    #110
  11. Eikester

    Eikester Possessed Armor

    Joined:
    May 24, 2011
    Messages:
    940
    Likes Received:
    1,576
    i have this problem sometimes if the steam servers are to busy or in maintenance, also i don't want to remove the steam check (its the same check that vanilla terraria uses)

    Also Updated to 3.2 to make it work with 1.2.0.2
    Updated the Downgrade Feature
    All content files will be patched too, that means if you play 1.0.4 your game looks like 1.0.4 (no more Textures/Sprites/Sounds of 1.2)​
    No Original Files will be shared this way, its only a bunch of Binary Diff Files​
    Currently 1.0.4 and 1.1.2 (more to come as soon as possible, nostalgia)​
    Still experimental feature, Crashes may happen, if so please report and i will look into it​
    !Backup your World/Player Files before downgrading​
    Downgrades will be installed into "Terraria\Older Versions\Terraria + vvvv" vvvv = Version Number​
    If you get a crash first try to delete the "config.dat" in "My Games\Terraria" (or rename)​
     
    #111
  12. Grox the Great

    Grox the Great Snatcher

    Joined:
    Mar 14, 2013
    Messages:
    236
    Likes Received:
    294
    Oh no, I was definitely not asking you to remove the steam check! I just wondered why the older version worked fine but this one did not. Thanks for clearing that up!

    EDIT: I am not sure that's the only cause. I just updated to the latest game launcher, and when I try to run 1.2.0.2 yet again it tells me to launch through steam. It did not work in all tries I have done between when I reported it and now, so steam server lag seems to be unlikely as the only cause. Did you change anything between the 1.1 and 1.2 versions that could have caused this? I AM using the game launcher through steam, so I don't see why it would say that.

    EDIT2: Ok I found the problem, the old game launcher asked me to provide admin permission when I launched it, the new one does not do this until I try to run 1.2 itself. When I changed the permission for the launcher, it fixed the issue.
     
    #112
    Eikester likes this.
  13. Eikester

    Eikester Possessed Armor

    Joined:
    May 24, 2011
    Messages:
    940
    Likes Received:
    1,576
    Released an new Update:
    Added Menuoptions to install Terraria Versions 1.0 and 1.0.6.1

    Edit:
    Updated to 3.2.0.2
    Added Terraria Version 1.0.5 Diffpatch
    Temp Files/Folders will be removed after installing a patch
     
    #113
    W1K, Bullseye55 and Tunnel King like this.
  14. Zero-Exodus

    Zero-Exodus Wraith

    Joined:
    Oct 8, 2011
    Messages:
    771
    Likes Received:
    1,033
    Oh Eikei how I love thee

    i'd love to go back... but then I miss the new stuff.... but I have no other way to play RTR and such and such...... impatiently awaiting tAPI
     
    #114
    Eikester likes this.
  15. Jegus

    Jegus Green Slime

    Joined:
    Oct 6, 2013
    Messages:
    1
    Likes Received:
    0
    Ever since 1.2, my installer refuses to make a TerrariaOriginalBackup.exe, which prevents me from installing tconfig (or even playing the vanilla game). What's up with that? Installation completes with no errors
     
    #115
  16. Klokinator

    Klokinator Angry Nimbus

    Joined:
    Dec 22, 2011
    Messages:
    821
    Likes Received:
    684
    I may need to rewrite my pinned tutorial for 1.2 unless much hasn't changed?
     
    #116
    Tim Hjersted likes this.
  17. Eikester

    Eikester Possessed Armor

    Joined:
    May 24, 2011
    Messages:
    940
    Likes Received:
    1,576
    have you tried with a clean install of Terraria? I mean redownload trough Steam (verify Cache) and then installing Game Launcher again? Also tConfig is discontinued and will not work with 1.2, you can install 1.1.2 trough the Game Launcher Menu ("Older Terraria Versions") and point the tConfig Installer to the new subfolder "Older Versions\Terraria 112" and use "Add App" to manually add tConfig to the Apps list (maybe someone can explain this better because my english sucks lol)

    Edit: just noticed i made a typo in the inno setup script (i hate the what ever language it is lol)
    should now work
     
    #117
  18. Darkercloud

    Darkercloud Lava Slime

    Joined:
    Nov 27, 2011
    Messages:
    898
    Likes Received:
    245
    Can you add 1.2, 1.2.0.1 on installing older versions?
     
    #118
  19. R5N250E24

    R5N250E24 Snow Flinx

    Joined:
    Aug 25, 2012
    Messages:
    344
    Likes Received:
    22
    how to get tccl to launch
    it doesn't appears in the list and if i try to put it into the list my self it won't start
     
    #119
  20. alely

    alely Cursed Man

    Joined:
    Jun 3, 2013
    Messages:
    12
    Likes Received:
    1
    How to uninstall? :/
     
    #120
Thread Status:
Not open for further replies.

Share This Page