[HOW TO] Connecting to your own server (With or without Hamachi)

Discussion in 'In-Game Support Archive' started by Sykes, May 19, 2011.

  1. Sykes Green Slime

    Quick Answer: Use your Local IP. Read below for details.

    There is some confusion as to how to connect to your own server, while running it in another instance of the game. Many people are making lots of different threads about the same problem, and none of you seem to care to check the "Guides" section of the forums, and if so, you must have skipped over the guides on how to do this. I'm going to use simple terms so people can understand and relate, so if you net gurus want to nit pick, do it in PMs because I'll gladly chat about this.

    First off, there are 3 different common IPs you can use:

    External IP: What people type to connect to you. Whether through Hamachi, or what you get from visiting www.whatismyip.com. Do not use when connecting to your own server. It MAY work, there have been reports of it, but chances are it won't.

    Local IP: This IP looks like 192.168.xxx.xxx, and it is NOT 192.168.1.1, which would be your router, unless configured otherwise, but if your router is configured like that then chances are you wouldn't be reading this. Use this IP when connecting to your own server.

    Internal Loopback: This IP is 127.0.0.1, or localhost, and basically means "Me" or "My computer". Unfortunately, this will not work in Terraria for whatever reason. Do not use this to connect to yourself.

    So give your friends your External IP, and connect with your Local IP yourself. Here's how to find your Local IP in Windows 7:

    • Open up the Network and Sharing Center by right clicking the Network icon on your task bar, next to your clock.
    • Click "Change adapter settings" in the upper left-hand side.
    • Right click the network adapter you use to connect to your router/the internet (this does not mean Hamachi's adapter!), and click "Status".
    • Click the "Details..." button.
    • Find your "IPv4 Address", which should start with 192.168, and connect to yourself with that address every time. NOTE: It's subject to change depending on your network configuration. Double check it if you can't connect anymore
    Hopefully, this should clear things up. If things STILL don't work, feel free to PM me.
  2. Triple Omega Green Slime

    This won't work if Terraria is listening to a different network adapter. For me only hamachi works. This is probably due to network adapter priority, as hamachi creates its own and puts it at the top of the list.
  3. WVRockstar Green Slime

    Disable all network connections except the one for your internet.
  4. Kane Administrator

    Yup that is a key one. Also reset the game after you did it.
  5. Thrillho Green Slime

    I'd just like to say that if you are not connected to any network (wireless or wired) internal loopback will work.

    At least it does for me.
  6. Matt Olivera Green Slime

    Easier to just do this:

    Start --> Run...

    Type in: cmd
    type in: ipconfig /all
  7. Sykes Green Slime

    Matt Olivera, if you know how to do that, that's great, especially in Windows XP (because I forget how to access Network settings in that OS). But some people get freaked out by command line so I decided to explain it the "easy" way.

    And yeah, the devs have said that it prioritizes certain network adapters over others, so this may not work for everyone. It's my opinion that Hamachi should not be used unless port forwarding is impossible (like no access to the router), but in that case I would just recommend joining someone else's server with your friends. I play in a large group of people and we've never had a problem hosting normally, but then again we're all pretty experienced with this stuff.

    If you still can't get anything to work, PM me and you and your friends can play on one of my servers ;)
  8. xXKiLLa_PeNgUinXx Green Slime

    i was on the phone with my friend that was trying to connect to my server that i was hosting i gave him my external ip and it asked for the port which was 7777 and he never connected idk wat was wrong
  9. Rydian Blood Crawler

  10. bdr9 Green Slime

    I've been using 127.0.0.1 for a few months to connect to my own server, and it works perfectly fine.
  11. xXKiLLa_PeNgUinXx Green Slime

Share This Page