PC Microsoft XNA Framework 4.0 problem

Discussion in 'Technical Support Archive' started by Kaboshi, May 19, 2011.

  1. Kaboshi Green Slime

    So I've been trying to get Terraria to work for the past day. I'm pretty sure its a XNA problem by now but I can't find a solution.

    I am having trouble installing XNA.

    I have tried reinstalling .NET before installing XNA manually, I tried reinstalling via steam. I have updated .NET before installing XNA.

    When I try to install XNA manually, I get a error code: 2908
    I also get this message :
    An error occured during the installation of assembly 'Microsoft.Xna.Framework.Avatar,fileversion="4.0.20823.0",version="4.0.0.00000",culture="neutral",publicKeyToken="842CF8BE1DE50553",processorArchitecture="MSIL".

    When I try to install XNA through steam the install will loader up, act like its installing and then close.

    If anyone has encounter this same problem and fixed it, please help a guy out, thanks.
  2. Disorbia Green Slime

    exact the same problem
    also getting the 2908 error code
    i dont think there is a fix for this.. the only solution we can hope for is that the terraria
    developers will change the way the game works
  3. Nevemoth Demon Eye

    XNA 4.0 worked fine for me. What version of Windows are you using, and did you have .NET or XNA installed before installing Terraria?

    Try uninstalling Terraria (if it's installed yet), uninstalling the .NET framework, uninstalling whatever XNA stuff you already have and then follow these steps:

    1. Download and install this: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7
    2. After that is finished installing, download and install this: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a88c6dec-aeae-42cd-a108-d35c013c3b97
    3. After you've completed those steps, go back into Steam, and reinstall Terraria. It should skip the .NET and XNA installers, and should load up just fine.
  4. Zarat Green Slime

    Like I posted in that other thread with the same problem
    edit: on the other thread we figured out the hresult error code which was 0x8002802F and (according to google) seemed to indicate a corrupted .NET framework installation, which could eg. happen when the installation was aborted for some reason. While google says it should be possible to run a "repair install" on the framework, unfortunately it didn't help for the case in the other thread. Note that your hresult code may be different though.
  5. Kaboshi Green Slime

    So you're saying there is not a fix for this problem yet? well darn it.
  6. Gamb Green Slime

  7. Kaboshi Green Slime

    I ran that tool and it failed to verify. I have a whole text log, i can upload it if it will help me with the issue.
  8. Zarat Green Slime

    Uploading the log probably will help because it'll give the devs more info to look into (once they are back).
    For reference here's a link to another relevant article, it might not help you directly, but it might be useful for the devs or anyone else looking into the issue and has technical background:
    http://blogs.msdn.com/b/astebner/archive/2010/12/29/10110053.aspx

    I'd look into it but I have to go to work now. :(
  9. Gamb Green Slime

    Ah, so it does seem to be an issue with the net framework! :eek:

    Please post!
  10. Zarat Green Slime

    In the article I posted above it says mscoree.dll could have failed to update when installing .NET framework 4, and the installer may not be aware of it. Go into your windows system32 and/or syswow64 folder and check the properties of mscoree.dll - if it's version 2.0 instead of 4.0 then the .NET framework didn't install correctly. See that article for more info.
  11. n00blet Green Slime

    Is terraria ever going to release a non-xna version of the game because the only thing stoping me from buying it now is it needs xna. I mean does the game REALLY need xna games like half life and portal dont need it, why does a 2d side scroller? Minecraft has lower hardware requirements right now(not saying its a clone just comparing)
  12. Zarat Green Slime

    They probably used XNA because it's a full game framework, cutting down their development time a lot. For that very reason it's unlikely that they switch away anytime soon.

    BTW that's offtopic since even without XNA the error in this thread would prevent one from running .NET 4.0 programs, as the framework itself isn't correctly installed.
  13. n00blet Green Slime

    If the game was in java there wouldn't be any all the .NET problems either and it would be compatible with almost every os. I just don't see why they would choose this bass ackwards way of doing things, ALOT of paying customers are not even able to play the game because of XNA.
  14. Kaboshi Green Slime

    You nailed that. What article should I be looking for?

    And gamb, I uploaded the log in this post for you also.

    Attached Files:

  15. Zarat Green Slime

    @nooblet - if they had coded it in java they'd have to do more coding work and would probably not be finished yet. XNA provides a lot of what you'd have to do yourself in java. Besides, you shouldn't underestimate the time it takes to learn a language and its framework, who knows if they are fluent in java. Anyways, it's the way it is now, and changing it would take several months of recoding, so that's not going to happen anytime soon I'd guess.

    @kaboshi
    The article I linked above, http://blogs.msdn.com/b/astebner/archive/2010/12/29/10110053.aspx
    Basically it's saying you need to repair windows. In the last paragraph he's got a link to a tool which can diagnose/fix registry errors - http://support.microsoft.com/kb/947821/en-us (and hopefully can tell you wha to fix) - if I understood it correctly, once the registry is fixed you can reinstall .NET 4 properly. However I have no idea if you need to uninstall it before attempting to fix the registry.

    He got another article where he describes other symptoms (you may want to check if you experience them too) and a possible way to cure them (also linked from the last paragraph of the original article), but it's not a guaranteed fix - http://blogs.msdn.com/b/astebner/archive/2009/01/09/9303167.aspx

    If you want to take a try you could download that tool (System Update Readiness Tool - make sure you take the correct version for your OS/CPU!) and post the log, or go along with his guide to fixing the thing.

    To be honest I'm a bit lost myself, it seems to be a very complicated problem. He says the only solution which is guaranteed to work is to reinstall windows.
  16. Gamb Green Slime

    [05/19/11,22:05:41] Not running action 'Registry - .NET Framework 4 Full (32-bit)' for product '.NET Framework 4 Full' because the OS condition does not match

    What operating system are you running? Is this XP? If so: are you on service pack 3?
  17. Kaboshi Green Slime

    I'm running windows 7
  18. nbeerbower Green Slime

    Hey everyone! I was having the same exact problem! In fact, none of my programs that used .NET 4 would work! But I've been searching the internet to fix this bug.

    The problem is the result of the .NET 4 installer never updating mscoree.dll from .NET 2. So, here is the new dll and some instructions on how to fix it.

    http://www.megaupload.com/?d=MBCL8TKC
    (if for some reason you don't trust the download see here http://social.msdn.microsoft.com/Forums/en/vssetup/thread/a09baa85-635d-420c-a88a-de05f75c8140 to obtain it a different way)

    -nbeerbower

    P.S. Make sure you restart your computer afterwards!
    bobreeda and Kaboshi like this.
  19. Kaboshi Green Slime

    This worked like a charm, THANK YOU VERY MUCH nbeerbower ^_^

    I feel this information should be a sticky thread somewhere on the forum.
  20. Fertix43 Green Slime

    nbeerbower, you are my hero, thank you so much, this actually finally worked. ^^ Greatly appreciated, I've been trying to get this game to work all week and finally get to play it.

Share This Page