Stuck on connecting to server (hosting issue)

Discussion in 'In-Game Support Archive' started by Plattack, Jun 4, 2011.

  1. Plattack Green Slime

    So I tried to host a server from the terrariaserver.exe several times over the past day. However, when I connect to my own server it gives me the "connecting to (ip here)" forever. No error screen or getting by it, it just sits there forever.

    I've tried it across several different ports, but it always does this. My friend got the same "connecting to (ip here)" hanging there when he tried joining my server.
    (Yes, we were using the external IP.)
  2. Kald Cursed Man

    Have you forwarded the port you are using?
  3. Plattack Green Slime

  4. Kald Cursed Man

    It could be your anti-virus that's stopping it, some of them don't like letting games through. You could try temporarily disabling it to see if that allows you to connect, and if it works, you could go about setting it to let the Terraria server through.
  5. Janin Green Slime

    I have this same issue and anyone trying to connect to me.
    I'm on Win Vista (I know, bad to start with). I have a BT Home Hub 2, which has the port forwardings set up, my firewall is also set correctly. The problem is my router/hub doesn't appear to recognise the ethernet cable from it to my pc. It see's wireless happily, and even random usb peripherals attached to it.
    No matter what I've done it still says 'not connected' for the ethernet. I'm assuming it can't forward to something it doesn't think is there.

    It's very frustrating since I set up a new world for friends with an NPC tower and starter spawn area...and now no-one can connect to it.

    Obviously if the OP problem is you're just doing it for yourself, type in 'localhost' instead of the actual ip and you can connect to your own well enough :)
  6. Rider2011 Green Slime

    Try a different cable, not sure why the one your trying to use now isnt working, also check make sure that the NIC isnt disabled or not functioning properly in your device manager.
  7. Janin Green Slime

    I'm not sure what NIC is :\
    I had a little help checking a lot of things after giving it a go myself :D
    I don't have a spare cable unfortunately either. But I am connected via the current cable, just that the home hub config page doesn't see that the pc is connected...it's just odd.
  8. Kald Cursed Man

    @Janin-
    An NIC is a network interface card, what you'd connect your ethernet cable to. I don't think that's the issue if you are connecting to the internet just fine, I'm pretty sure it has something to do with your BT Home Hub 2. I read online that others have had similar problems with your piece of hardware, but there weren't any clear solutions, else I'd try to help you with it.

    Also, I would have told the OP to just use localhost, but since his friend couldn't connect either, I figured I'd try to go a different route.
  9. Janin Green Slime

    @Kald, aha, thanks! Had a feeling it was something to do with the network card but wasn't entirely sure...and the last thing I need to do is mess with something by mistake!

    Oh, and yeah, hadn't remembered OP's friend got the same thing. D'oh.

Share This Page