TEdit - Terraria Map Editor

Discussion in 'Released Mods' started by BinaryConstruct, Jun 26, 2011.

  1. connery0

    connery0 The Wiremancer

    Joined:
    Jun 4, 2011
    Messages:
    2,384
    Likes Received:
    1,059
    1) you can zoom in by scrolling, when zoomed out you won't see textures because it wouldn't be visible in the first place
    2) if you havn't bought terraria from steam you won't get sprites
     
    #1741
  2. Shannara

    Shannara Cursed Man

    Joined:
    Aug 27, 2011
    Messages:
    8
    Likes Received:
    0
    Thank you for the reply :)

    1. Zooming doesn't make a difference of texture visibility :(
    2. I bought Terraria from steam, sprites do not show.
     
    #1742
  3. Tim Hjersted

    Tim Hjersted Vampire

    Joined:
    Dec 8, 2011
    Messages:
    1,469
    Likes Received:
    845
    #1743
  4. Shannara

    Shannara Cursed Man

    Joined:
    Aug 27, 2011
    Messages:
    8
    Likes Received:
    0
    I have the latest TEdit already. What is the schematics link for?
     
    #1744
  5. Shannara

    Shannara Cursed Man

    Joined:
    Aug 27, 2011
    Messages:
    8
    Likes Received:
    0
    Unfortunately, it looks like TEdit is abandonware, and doesn't work with the current version of Terraria :( Are there any replacement map editors out there?
     
    #1745
  6. connery0

    connery0 The Wiremancer

    Joined:
    Jun 4, 2011
    Messages:
    2,384
    Likes Received:
    1,059
    It definatly isn't abandomware, it's the best program to edit maps there is for teraria (prety sure it's also the only one) you could try buildaria, it basicly gives you godmode and infinite recources but it still isn't as usefull as Tedit (in my opinion)

    have you also installed terraria on the machine you want to use Tedit? it uses terrarias files for the sprites

    It used to create a error log when it couldn't find the sprites that told you that, but I think that's gone (or I'm doing something wrong)
    anyway,...

    this is what you see if you have a illegal version of terraria or if you don't have terraria installed:
    [​IMG]
    (I gues this is what you see)

    this is what you see if you have the normal version/if you have it installed:
    [​IMG]

    So yes it still works with the current version, I'm prety sure you will still be able to place the current blocks once 1.2 comes out, you just won't be able to place the newly added ones, until it updates.

    ps: you should merge your last 2 posts, there are rules against double posting
     
    #1746
    Tim Hjersted likes this.
  7. Shannara

    Shannara Cursed Man

    Joined:
    Aug 27, 2011
    Messages:
    8
    Likes Received:
    0
    Well, unless Steam is giving out illegal versions of Terraria, I have a legal version of Terraria, and see the first picture. But from my view, it is abandoned as it only shows the first image (no textures), on legal (steam) version of Terraria.

    I'll try buildaria to see if its still being developed and works with the current version of Terraria.
     
    #1747
  8. connery0

    connery0 The Wiremancer

    Joined:
    Jun 4, 2011
    Messages:
    2,384
    Likes Received:
    1,059
    You should chek if terraria is installed at "C:\Program Files (x86)\Steam\steamapps\common\terraria" because it will only look there for the textures (I wanted to avoid saying that, because it's the only way Tedit checks if its a legit version,... So make sure all terraria files are in there)

    I'm prety sure it's just program files instead of program files x86 on 32-bit computers though
     
    #1748
  9. rubeszilla

    rubeszilla Tortoise

    Joined:
    Jun 15, 2011
    Messages:
    1,736
    Likes Received:
    1,739
    Yep, I believe connery0 is correct. I have a legit steam copy too but recently reinstalled all my programs on a separate drive, now Tedit doesn't show the sprites. Gotta have em on C:\ sadly.
     
    #1749
  10. Shannara

    Shannara Cursed Man

    Joined:
    Aug 27, 2011
    Messages:
    8
    Likes Received:
    0
    connery0, thanks for the info. That is a HUGE bug in TEdit. Steam allows you to install games in any directory you like. I have all of my steam apps on my D drive since it is an SSD.

    Ok, so now we have the issue narrowed down to a bug in TEdit.
     
    #1750
  11. connery0

    connery0 The Wiremancer

    Joined:
    Jun 4, 2011
    Messages:
    2,384
    Likes Received:
    1,059
    I think it's not realy a bug but just a way to see if it's a legit version, of course if you know this you can also run Tedit by just creating that folder. That's also the reason I didn't want to tell that, a few people literaly have come to this thread before to ask how to run this on a pirated copy so that's why I was suspecting you (sorry for that) :rolleyes:

    Glad to hear you got it worked out though,... If you realy want to keep the game where you installed it, only copying the "C:\Program Files (x86)\Steam\steamapps\common\terraria\Content\images" could help, but I havn't tried that
     
    #1751
  12. BinaryConstruct

    BinaryConstruct Voodoo Demon

    Joined:
    May 20, 2011
    Messages:
    347
    Likes Received:
    360
    I am sorry you have been having issues, TEdit uses the steam registry and falls back to program files if it is not located (see DependencyChecker.cs). A recent steam patch introduced some complexity rendering this logic invalid in some cases. There is an issue on github associated with this https://github.com/BinaryConstruct/Terraria-Map-Editor/issues/337. In a future release I will add a dialog where you can choose the folder Terraria is installed to for sprite loading. Note: if Terraria is found, there should be a message indicating the path in the log file. As a temporary fix you could create dummy folders in program files (x86)\Steam\steamapps\common\ that contains a ntfs symbolic link to the Terraria folder.
     
    #1752
  13. Dragonized

    Dragonized Illuminant Slime

    Joined:
    Nov 20, 2011
    Messages:
    1,285
    Likes Received:
    1,102
    BinaryConstruct, the god among men.
     
    #1753
  14. Nick Walraven

    Nick Walraven Green Slime

    Joined:
    Jul 3, 2013
    Messages:
    1
    Likes Received:
    0
    The adf.ly link on your website doesn't work, mind taking a look at it?
     
    #1754
  15. SamothUpaw

    SamothUpaw Face Monster

    Joined:
    Oct 4, 2011
    Messages:
    979
    Likes Received:
    622
    BC, are you going to remake this for 1.2?
     
    #1755
  16. BinaryConstruct

    BinaryConstruct Voodoo Demon

    Joined:
    May 20, 2011
    Messages:
    347
    Likes Received:
    360
    It seems to be working for me. If you are still having issues, I will try to get a mirror up.

    I plan to. https://github.com/BinaryConstruct/Terraria-Map-Editor/issues/355
     
    #1756
  17. SamothUpaw

    SamothUpaw Face Monster

    Joined:
    Oct 4, 2011
    Messages:
    979
    Likes Received:
    622
    #1757
    Wavve likes this.
  18. Towel

    Towel Angel Statue

    Joined:
    Jul 3, 2013
    Messages:
    2
    Likes Received:
    2
    First off I love the program to death and you are an amazing person, Binary. But that's not really the reason I'm here.

    I've been having a strange issue of not being able to open and edit worlds that are in my Terraria worlds folder. It just comes up with this (Image). If I copy the world file to another folder, it works just fine. For some reason the issue also happens in a folder inside the folder that works. Might Tedit not like handling folderception or is there something else going on?

    This has only been happening recently though. It seems to have started to happen after I got Tshock for a server I'm running. Might that be part of the issue?
     
    #1758
  19. BinaryConstruct

    BinaryConstruct Voodoo Demon

    Joined:
    May 20, 2011
    Messages:
    347
    Likes Received:
    360
    This is a known issue with file associations, usually occurring when double clicking a file in paths with special folders. Here is the issue if you wish to track its progress. https://github.com/BinaryConstruct/Terraria-Map-Editor/issues/341
     
    #1759
  20. AdenSword

    AdenSword Toxic Sludge

    Joined:
    May 29, 2011
    Messages:
    1,285
    Likes Received:
    740
    it wants to give me an installer when i try to get it and when i install it i cant pop it up
    HELP PLEASE ive got some ideas for adventure maps i want to make
     
    #1760

Share This Page