Pre 1.2 Terraria GameLauncher - A way to load multiple mods through Steam

Discussion in 'Released Mods' started by plaYer2k, Sep 13, 2011.

Thread Status:
Not open for further replies.
  1. Eikester

    Eikester Possessed Armor

    sry for Doublepost

    Version 0.3 is now Online, Link in OP is still the same!

    Added Doubleclick feature, Thanks 7UR7L3
     
  2. 7UR7L3

    7UR7L3 Undead Viking

    Sure thing, I was kinda wondering why it wasn't implemented.
     
  3. Bobrocket

    Bobrocket WANTS TO PUNCH STUFF

    I have a bug report.
    When I click launch game (with latest tConfig) I get the "Please run this game through your steam client" error.
     
  4. Eikester

    Eikester Possessed Armor

    not a bug, go to your steam library and start Terraria->this opens the Game Launcher->select the Game you want and Doubleclick or click the Launch Button
     
  5. Bobrocket

    Bobrocket WANTS TO PUNCH STUFF

    I fixed it, just had to relaunch the game launcher :)
     
  6. Slangword

    Slangword Mouse

    Assistance please!

    I have the ability to open up various mods through this program, but since the latest update, I'm now unable to open up Terraria 1.0.6.1. The only way I can is if I delete the mod/game launcher... Any ideas on what's happening and how to fix it? Could you give me a link to an older version that still works correctly?
     
  7. Eikester

    Eikester Possessed Armor

    The GUI Version comes without the needed TerrariaOriginal.gli, i'll update the GUI later with this file included, so long you can download the Archive with the Console version by player2k which includes this file.
     
  8. Slangword

    Slangword Mouse

    I appreciate you replying promptly. So I just downloaded Release 2 which had the necessary file (TerrariaOriginal.gli). I then deleted GameLauncher Installer and downloaded Release 3- now it works perfectly. Thanks for your help!
     
  9. Eikester

    Eikester Possessed Armor

    No Problem :)

    Does anyone have ideas or wishes to include? Cause atm i'm working on the Game Launcher.
    Small changes:
    Added Column Sort
    TerrariaOriginal.gli will now created on Installation
     
  10. ahamling27

    ahamling27 Map Expert/Admin Staff Member

    Would it be possible to make your texture pack loader universal, so any of the other mods could be loaded with it?
     
  11. Roll Volnut

    Roll Volnut Cursed Skull

    I have an error. I just installed this, and I've installed it before, but I had to delete all of my Terraria stuff. I had played for about an hour and a half before I installed this, and now look at this. wtf.png
    Terraria itself isn't there.
     
  12. Eikester

    Eikester Possessed Armor

    Uploaded an little Update (0.4)

    Main Reason is to make sure Terraria appears in the List for users who only downloaded the GUI version.

    also Added Column Sort and Fixed Thread causes InvalidOperationException

    Other planned features will be added in the next Version!
    Hope this version now works for everybody without problems.

    EDIT:
    as long as the Mod comes with a gli File it could be loaded.
     
  13. Vegemight

    Vegemight Green Slime

    i cannot load the original terraria game from this mod and so far all people who have had the same problem get a code-speak jargon reply :p anybody know how to easily uninstall this mod or get the original terraria on the list willing to explain it to a non-computer-speaker-man?
     
  14. Roll Volnut

    Roll Volnut Cursed Skull

    Download it again, it was updated.
     
  15. Vegemight

    Vegemight Green Slime

    woohooo! awesome! thanks you!
     
  16. Kinasin

    Kinasin Bunny

    Is there a way to get all these separate mods working together with this? Like cmod and modpacks and ike custom content loader??
     
  17. ShinkuOokami2323

    ShinkuOokami2323 Doctor Bones

    Alright, I need help. I'm new to mods of all sorts, so you might have to dumb it down for me. I'm lucky that I understadn what .exe is. Lol. So, I downloaded this, and as soon as it came up.. this si what it said on the 'log' tab:

    Installing GameLauncher GUI version..
    Error: Could not locate you original Terraria build
    May you use a newer version? Check updates
    Also make sure you run this file from within your terraria directory'... \Steam\Steamapps\common\terraria\'
    missing: C:\Users\Elijah\Desktop\Terraria.exe
    missing: C:\Users\Elijah\Desktop\TerrariaOriginalBackup.exe
    missing:
    There. thats EXACTLY what it said. Down to the capitilization. Can anybody help? The normal Terraria seems to work fine. After that happened, I tried opening Terraria through Steam, and it opened fine. Even used a character, and got onto a world. So the actual game works perfectly fine. So.. what should I do? I actually downloaded this so I could use Cmod.
    Thanks in advance,
     
  18. Mathew Sky

    Mathew Sky Doctor Bones

    Don't see why the texture pack app thing doesn't use this.. it will expand popularity of texture packs AND you. This has alot of potential with the Terraria community, thank you.

    Read the readme, from my memory I think there was one, otherwise read the installation instructions [if there is any] in the OP, it says you have to put it in your terraria content folder.
     
  19. ShinkuOokami2323

    ShinkuOokami2323 Doctor Bones

    Well, see.. Thing is, I can't find the actual file to drop it into the folder.. Lol.
     
  20. TWWalker

    TWWalker Green Slime

    how do i change window resolution without wrapper now?
    i used to have custom resolution by using RomTerraria
    is there a way to put RomTerraria in Terraria GameLauncher?
    i'm using Terraria GameLauncher GUI v0.4
     
Thread Status:
Not open for further replies.

Share This Page